Incident

Service Disruption

Resolved | Mar 11, 2021 | 16:05 GMT+11:00

All services are operating as normal again. Thank you for your patience.

Affected components

  • Drawboard Projects Cloud API - Production

Investigating | Mar 11, 2021 | 12:13 GMT+11:00

There is currently an incident impacting our cloud services where connectivity to our services such as syncing, authentication and exports are intermittently affected.

We are actively investigating and remediating this as we speak and will keep you updated on the status of the issue.

We apologise for the disruption and any inconvenience caused. Thank you for your understanding and we look to resolve this soon.

Status Page powered by Admin Labs